Mikrotik Script Blok Torrent

Berikut ini Script di Mikrotik untuk memblokir koneksi torrent yang kami dapatkan dari forum mikrotik. Script ini langsung bisa di paste di Terminal mikrotik. Script ini menggunakan funsgi di Mikrotik Firewall dengan menggunakan 5 rule untuk membloking.

Port/service yang digunakan untuk bloking sebagai berikut :

  1. Layanan p2p=all-p2p
  2. Konten yang biasanya merupakan file torrent, content=d1:ad2:id20:  dst-port=1025-65535 packet-size=95-190 (UDP)
  3. Konten : content=”info_hash=” dst-port=2710,80 (TCP)
  4. Konten : content=”\r\nContent-Type: application/x-bittorrent” protocol=tcp src-port=80
  5. Lokal Broadcast : content=”\r\nInfohash:” disabled=no dst-port=6771 (UDP)

/ip firewall filter
add action=drop chain=forward comment=”TORRENT No 1: Classic non security torrent” disabled=no p2p=all-p2p
add action=drop chain=forward comment=”TORRENT No 2: block outgoing DHT” content=d1:ad2:id20: disabled=no dst-port=1025-65535 packet-size=95-190 protocol=udp
add action=drop chain=forward comment=”TORRENT No 3: block outgoing TCP announce” content=”info_hash=” disabled=no dst-port=2710,80 protocol=tcp
add action=drop chain=forward comment=”TORRENT No 4: prohibits download .torrent files. ” content=”\r\nContent-Type: application/x-bittorrent” disabled=no protocol=tcp src-port=80
add action=drop chain=forward comment=”TORRENT No 5: 6771 block Local Broadcast” content=”\r\nInfohash:” disabled=no dst-port=6771 protocol=udp

mikrotik-block-torrent-work-2016

Script ini terakahir saya test dan berjalan baik di Mikrotik versi 6.33.3 pada Mesin Mikrotik CCR, jika ada masalah anda bisa bisa berbagi di form koemntar dobawah ini.

Sumber : http://forum.mikrotik.com/viewtopic.php?t=95352

Leave a Reply

Your email address will not be published. Required fields are marked *